Brake lights not working - Redline UTV Forums - Redline Riot & Redline Revolt Community
Lighting, Stereo, and Electrical For Electrical Discussion!

 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 02-27-2014, 09:23 PM Thread Starter
 
Join Date: Sep 2013
Posts: 131
Brake lights not working

Just picked up a 07 revolt going through everything I found the brake lights bar Doesn't work. Has this been a common thing. I haven't put a meter to it yet but I would doubt the light is actually bad. Anyone experienced this?
Longball is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 02-27-2014, 09:40 PM
 
Join Date: Jan 2014
Location: Oregon
Posts: 17
Re: Brake lights not working

check the hydraulic brake switches on master cylinder, one is for the starting with brake pedal depressed and one is for the brake light. that should get you started. I replaced both of mine when I got it, guy I bought it from bypassed the switch for starting it so you wouldn't have to start it with brake pedal depressed, also found my brake light was a taillight only, I added l.e.d. tape light on rear and hooked those into new brake switch, looks and works great
XXXwaldoXXX is offline  
post #3 of 4 (permalink) Old 02-27-2014, 10:41 PM
 
SilverSquirrel's Avatar
 
Join Date: Jan 2013
Location: Fresno, CA
Posts: 22
Re: Brake lights not working

Quote:
Originally Posted by XXXwaldoXXX View Post
check the hydraulic brake switches on master cylinder, one is for the starting with brake pedal depressed and one is for the brake light. that should get you started. I replaced both of mine when I got it, guy I bought it from bypassed the switch for starting it so you wouldn't have to start it with brake pedal depressed, also found my brake light was a taillight only, I added l.e.d. tape light on rear and hooked those into new brake switch, looks and works great
I had the same issue. But instead of replacing the pressure activated switch I just connected the brake light to the brake safety switch instead. It was the day before I left on a trip so didn't have to many choices. It worked out great and I don't plan on changing it. You obviously lose that safety feature but I prefer not to have it in the first place.
SilverSquirrel is offline  
Sponsored Links
Advertisement
 
post #4 of 4 (permalink) Old 02-27-2014, 10:52 PM Thread Starter
 
Join Date: Sep 2013
Posts: 131
Re: Brake lights not working

I will try that thx guys!
Longball is offline  
Reply

  Lower Navigation
Go Back   Redline UTV Forums - Redline Riot & Redline Revolt Community > Technical > Lighting, Stereo, and Electrical

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Redline UTV Forums - Redline Riot & Redline Revolt Community forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











  LinkBacks (?)
LinkBack to this Thread: https://www.redlineutvforums.net/lighting-stereo-and-electrical/2413-brake-lights-not-working.html
Posted By For Type Date
RedlineUTVForums.net This thread Refback 03-18-2014 02:59 PM

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome