New engine - Redline UTV Forums - Redline Riot & Redline Revolt Community
Engine For Discussing the Redline engine topics!

Reply
 
LinkBack Thread Tools Display Modes
post #1 of 58 (permalink) Old 03-21-2010, 10:20 PM Thread Starter
 
jtap00's Avatar
 
Join Date: Apr 2009
Location: Oregon
Posts: 142
New engine

Has anyone tried to put any other engines in there Revolts. If you have I would like to know if you ran into any problems that you did not see coming. I have started putting a Polaris 800 RMK snowmobile engine in. The engine fits in the Revolt really nice and looks like it will work well. The biggest problem so far is the exspansion chamber and muffler, making it fit is a challange. When I get it running it puts out 140-hp and thats stock.
jtap00 is offline  
Sponsored Links
Advertisement
 
post #2 of 58 (permalink) Old 03-21-2010, 11:47 PM
 
offroadpro4's Avatar
 
Join Date: Jul 2008
Location: San Diego, CA
Posts: 719
Re: New engine

nice..........
It would be cool to see some pics, and some vids..
keep us posted...
offroadpro4 is offline  
post #3 of 58 (permalink) Old 03-21-2010, 11:55 PM
Official Site Vendor
 
Red Rock Powersports's Avatar
 
Join Date: Sep 2008
Location: St. George, Utah
Posts: 1,331
Re: New engine

Jeff,

It is good to see you surface. I haven't heard from you for a while. Aren't you going on the ride with Team Oregon in a week or two? Sounds like quite a project. Are you going to be able to have it ready to roll? Knowing you, I probably should have asked that last question .

Mike

Problems? Questions? Need parts or Repairs? Send us an e-mail, PM, or Call (435) 705-9846

E-mail: [email protected]

Red Rock Powersports, LLC

Utah's Redline Dealer!
Red Rock Powersports is offline  
Sponsored Links
Advertisement
 
post #4 of 58 (permalink) Old 03-22-2010, 11:16 AM Thread Starter
 
jtap00's Avatar
 
Join Date: Apr 2009
Location: Oregon
Posts: 142
Re: New engine

Here are some pictures of the progress so far.


jtap00 is offline  
post #5 of 58 (permalink) Old 03-22-2010, 11:47 AM
 
four_by_nut's Avatar
 
Join Date: May 2008
Posts: 529
Re: New engine

MMmmmmmm...........tasty! That looks AWESOME!!! 140hp from an 800???? Sounds like a really SLICK upgrade for those that want to race something like that. I'm assuming that is two stroke though, right? Which, per racing rules, it too large. Has to be 400cc or less to be two stroke in most off road desert racing circuits like BITD etc.

Looks like you are going to need a serious heat shield to keep the exhaust from cooking the back of the seat!!

And you should go ahead and order a replacement transmission now! Your going to need it!!!!! Or look to replace it with a beefier version. I think Ron (RRAWTRY on the forum) replaced his recently???
four_by_nut is offline  
post #6 of 58 (permalink) Old 03-24-2010, 05:49 AM
 
Join Date: Feb 2010
Posts: 34
Re: New engine

Nice job!!

800 twin 2 stroke 140hp sled motor!! That thing is going to be insane. There is a guy on youtube that did the same conversion in a Honda Pilot, watch the video you will be horrified. The stock tranny holds up just fine (its a Honda)

I would not worry about heat that much as 2 strokes run way cooler than 4 strokes, a simple heat shield or header wrap will do wonders. The only thing I see that concerns me is the length of that Y pipe is pretty long for a 2 stroke. That motor may run differently than it did in the sled. Have you thought of modifying the factory Polaris expansion chamber to help make that 90 degree turn?? I know its easier said than done. You did a really nice job!!

Please keep us posted on this one
acusports is offline  
post #7 of 58 (permalink) Old 03-24-2010, 08:53 AM Thread Starter
 
jtap00's Avatar
 
Join Date: Apr 2009
Location: Oregon
Posts: 142
Re: New engine

That is the stock Y-pipe that I cut apart and made longer so I could get from behind the seat. The exspansion chamber I have also cut apart and took the volume from the longer header pipe and removed it from the exspansion chamber. Im sure you are right about it will not run the same as the sled. If the pipe does not work right I will find someone that knows about them and have one made that does work, but I have to try.
jtap00 is offline  
post #8 of 58 (permalink) Old 03-24-2010, 09:17 PM
 
Join Date: Feb 2010
Posts: 31
Re: New engine

How did the motor mounts line up? Also with your homebuilt pipe, if you "only" get 120-130 hp and can keep the pipe within the cage you will be doing great. Very nice work. Do you have a starter on this motor as well?
lutrev is offline  
post #9 of 58 (permalink) Old 03-25-2010, 09:09 AM Thread Starter
 
jtap00's Avatar
 
Join Date: Apr 2009
Location: Oregon
Posts: 142
Re: New engine

The motor mounts I took off the Weber engine and took very little mods so the mounts in to buggy it self were not touched. The mount took less then two hours to make.
The pipe will be in the cage and should have it done today.
The engine I have in the car now come with a starter but the model of sled I had did not come with a starter. I plan on adding a starter. I have to get the starter ring on the clutch and mount the starter on the engine. You can buy the kit to do this on e-bay.
jtap00 is offline  
post #10 of 58 (permalink) Old 03-25-2010, 06:10 PM
 
Join Date: Feb 2010
Posts: 31
Re: New engine

Thank you, cant wait to see a video of it running, good choice for a motor, tons of 800rmks out there, and lots of hop up parts if needed.
lutrev is offline  
Reply

  Lower Navigation
Go Back   Redline UTV Forums - Redline Riot & Redline Revolt Community > Technical > Engine

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Redline UTV Forums - Redline Riot & Redline Revolt Community forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











  LinkBacks (?)
LinkBack to this Thread: https://www.redlineutvforums.net/engine/772-new-engine.html
Posted By For Type Date
Redline UTV :: UTV Forums Network This thread Refback 03-22-2010 04:03 PM

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome